So, recently I've found myself becomng significantly more interested in software development/programming. I know we have a few programmers around here, and was curious on a couple things:
1) What language(s) do you know? If multiple, do you have a preference? (Excluding HTML and CSS)
2) What IDE do you use (if any)?
3) Do you have a particular naming scheme/notation system that you like to use for controls, and variables, like hungarian notation, a variation of Pascal/Camel Casing, etc...?
As for myself:
1) VB and C#.NET, a little C++, and a little more Java. I have a preference towards VB.NET because it was the first language that I learned, and have invested quite a bit of time into.
2) For VB, C#, and what little C++ I've done, I use Visual Studio. For Java I use jEdit.
3) Up until recently I used Hungarian Notation for naming all my variables and controls. I've broken away from that, in favor of using more readable names, utilizing camelCasing for variables and references, and PascalCasing for controls and methods. But I've found myself being tempted by hungarian notation for the controls, but for consistency's sake I try to avoid it, but still struggle with good names for differentiating my controls from my variables.
1) What language(s) do you know? If multiple, do you have a preference? (Excluding HTML and CSS)
2) What IDE do you use (if any)?
3) Do you have a particular naming scheme/notation system that you like to use for controls, and variables, like hungarian notation, a variation of Pascal/Camel Casing, etc...?
As for myself:
1) VB and C#.NET, a little C++, and a little more Java. I have a preference towards VB.NET because it was the first language that I learned, and have invested quite a bit of time into.
2) For VB, C#, and what little C++ I've done, I use Visual Studio. For Java I use jEdit.
3) Up until recently I used Hungarian Notation for naming all my variables and controls. I've broken away from that, in favor of using more readable names, utilizing camelCasing for variables and references, and PascalCasing for controls and methods. But I've found myself being tempted by hungarian notation for the controls, but for consistency's sake I try to avoid it, but still struggle with good names for differentiating my controls from my variables.