Page 2 of 10 FirstFirst 1234 ... LastLast
Results 41 to 80 of 400

Thread: Jedi Knight issues

  1. #41
    Child's Play CharityRibberium Mempyre!

    Posts
    12,497
    I think It's a good idea to add DF/JO/JA to this thread, since they are in the same series.
    So I'm going to bone up on them and see what works/doesn't. If anyone has anything to add to that feel free to post it.

  2. #42
    About to lose his freedom
    Posts
    3,772
    hrmmm ok, i am having what sounds like a similar problem as Chewbubba initially had. when i turn on 3d acceleration the screen goes black. i can still hear music and walking and blaster fire and such, just cant see anything.

    already tried -Windowgui command line thing and the ddraw.dll fix, but no luck. any advice???
    Welcome to the douchebag club. We'd give you some cookies, but some douche ate all of them. -Rob

  3. #43
    Child's Play CharityRibberium Mempyre!

    Posts
    12,497
    Try advanced display settings, who knows it might work.
    System specs?

  4. #44

    Win7 x64 can't do JKE

    I'm trying to get Jedi Knight Extended working for MotS. I have Win7 x64, and the Steam version of MotS. So far, it has worked okay for me in graphics and stuff. I want the videos I'm making to have the best quality graphics the modding community has to offer, so I went with JKE v1.0. The patch on it is outdated, and apparently the default Steam patch (v1.01) stinks, so I got the June 2008 patch. There is an alpha patch, but I haven't seen it yet. I ran the patch following the readme. Then I put the JKE files into the JK directory as per the readme. I ran the JKE.bat and it worked in Multiplayer (until I started screwing around with other stuff trying to get Single Player working). Single Player either goes black screen, crashes, or can't find the level. After that, I went with the Mazzter's 1.01 to 1.00 reverter, but I must be using it wrong, because no matter which one I choose, it has the original problems, plus a weird graphical glitch with the player model selection menu. Once I've got the answer, I might make a video tutorial for other helpless n00vices. Maybe. There just must be a start-to-finish, step-by-step manual from downloading the Steam game to firing up the hi-def mod. I think it will get more people to play the game.

    Is there any way to get JKE working with the latest patches (official or unofficial) so I can have all the graphical goodness of JKE in Single Player SW JK DFII MotS for Win7 x64?

  5. #45
    Child's Play CharityRibberium Mempyre!

    Posts
    12,497
    Wait, I don't get it.
    For MotS or JK? you say the JK folder but also say mots.

  6. #46

    NIKVMVS-REX-TODOA

    Posts
    16,996
    If it's for MotS, well, there is no JKE for MotS per se but you can just put JKE.gob in your MotS resource folder and it should work. Yes, even as a gob. However, for the Mara levels the guns won't be upgraded since they use different models.

    In any case, 16-bit mats cause the glitch in the player model selection menu and AFAIK it can't be fixed.
    Last edited by Nikumubeki; 07-24-2010 at 02:58 AM.

  7. #47
    Uh...correction: Is there any way to get JKE working with the latest patches (official or unofficial) so I can have all the graphical goodness of JKE in Single Player SW: JK: DFII for Win7 x64? I've been referring to JK this whole time, not MotS. It being an expansion pack, I thought the same patches and add-ons would apply for both. As such, the June patch is for MotS, not JK. The patch I should be using is the January 2008 patch for JK. The patch does not work with the Steam version that has the 1.01 LucasArts patch built in. After following the '08 patch's instructions, I get an error that says, "this game is unavailable, try again later." I guess it should also revert to the 1.00 version of JK, without the June 2010 LucasArts patch, but I couldn't figure out how to use the Mazzter reverter. The Mazzter reverter doesn't matter anyway because the January 2008 patch is an " - Update to LucasArts' JK v1.01," according to its description. That means that it shouldn't be 1.00 anyway.

    EDIT, sometime later: Okay, so I have .NET 2.0 installed along with JKLauncher, and according to the chat room, there's a patch that was released later than the January 2008 update. It isn't on the JKHub's Unofficial Patches page. It is barely different, so they didn't bother to put it on there: "this removes a seldom-seen limitation of mods only being able to spawn as many objects as listed in the loaded level's .JKL file." Here's the link to the tweak to the January patch. . The biggest difference is that the patches from the '08 patch are pre-applied to JK.exe, so all you have to do is dump JK.exe and JK.dll into your Jedi Knight directory. After I did that, I tested it out and it still works.
    Last edited by joel96; 07-24-2010 at 07:57 PM.

  8. #48
    To clarify and to sum up joel96's posts:
    He was trying to unofficially patch the Steam jk.exe, which is not possible with the existing unofficial patches. So, he replaced his Steam jk.exe with a pre-patched jk.exe that someone else made.


  9. #49
    Child's Play CharityRibberium Mempyre!

    Posts
    12,497
    And it worked? alright good.

  10. #50
    The second item in the original post...:
    2. JK Won't start, it crashes seconds after starting.

    ...should be changed to indicate more symptoms:
    2. JK opens, but screen is black or flickering; JK won't start; or JK crashes seconds after starting.

    There was a person that joined the #jkhub chat room to ask how to fix the black screen, even though he had read the forum post. The above word-change should make it clearer.


  11. #51
    Child's Play CharityRibberium Mempyre!

    Posts
    12,497
    WindowGUI on?

  12. #52
    About to lose his freedom
    Posts
    3,772
    does having a video card with directX 10 as its default make any difference?
    Welcome to the douchebag club. We'd give you some cookies, but some douche ate all of them. -Rob

  13. #53
    Imon, umon...everymon!
    Posts
    19,021
    "As it's default?" DX10 capable cards should be fine with the aforementioned patch, if that's what you mean.
    Bassoon, n. A brazen instrument into which a fool blows out his brains.

  14. #54
    Child's Play CharityRibberium Mempyre!

    Posts
    12,497
    It depends.

  15. #55
    I'm getting this:


    I have Windows 7, 64 bit.

    I've followed the steps at JKHub. Windows 7 doesn't allow you to change read only permissions (and take ownership plugin doesn't work), and I've made sure I installed the game properly (so I thought).

    Any ideas?

  16. #56
    For a good time, call 555-3985
    Posts
    906
    Quote Originally Posted by TSM_Bguitar View Post
    I'm getting this:


    I have Windows 7, 64 bit.

    I've followed the steps at JKHub. Windows 7 doesn't allow you to change read only permissions (and take ownership plugin doesn't work), and I've made sure I installed the game properly (so I thought).

    Any ideas?
    what version of 7 do you have?

    you should be able to change permissions, try turning off simple sharing
    If you want to play JK join the JK Chat on IRC @ irc.gamesurge.net Channel #jk I am the new Admin there! (JKLE_Cougar)

  17. #57
    Imon, umon...everymon!
    Posts
    19,021
    Simple sharing won't do anything
    Bassoon, n. A brazen instrument into which a fool blows out his brains.

  18. #58
    Windows 7 home premium. I'm pretty sure I've turned sharing off and it still will not let me change file permissions

  19. #59
    I have no idea what to do now. And windows 7 won't let me change the folders permission (the files themselves aren't read-only).

    I've tried just about everything (at least that I've found online) and I keep getting this no matter what

  20. #60
    For a good time, call 555-3985
    Posts
    906
    Quote Originally Posted by TSM_Bguitar View Post
    I have no idea what to do now. And windows 7 won't let me change the folders permission (the files themselves aren't read-only).

    I've tried just about everything (at least that I've found online) and I keep getting this no matter what
    you should have permission to change folder permissions unless you f***** something up...

    are you an admin?
    If you want to play JK join the JK Chat on IRC @ irc.gamesurge.net Channel #jk I am the new Admin there! (JKLE_Cougar)

  21. #61
    Imon, umon...everymon!
    Posts
    19,021
    What do you mean, it won't let you? Where is it installed? You have to be the owner to change permissions.
    Bassoon, n. A brazen instrument into which a fool blows out his brains.

  22. #62
    Child's Play CharityRibberium Mempyre!

    Posts
    12,497
    Make sure it's not set to read only. As for the permissiosn things I have no idea, try rebooting with UAC off and then turning it back on?
    (Don't keep it off that's a bad idea)

  23. #63
    you should have permission to change folder permissions unless you f***** something up...

    are you an admin?
    I am, there's only one account. I also just got this computer like a week ago and didn't really mess with any settings like that until today (after i couldn't get JK to work)

    It's not even showing me that it's denying it. I can change the permissions of the files, but the folders themselves remain read-only for some reason. I'll uncheck it, apply or okay it, then I reopen the properties and it's back to read-only.

    Very strange

  24. #64
    Quote Originally Posted by Tibby View Post
    Make sure it's not set to read only. As for the permissiosn things I have no idea, try rebooting with UAC off and then turning it back on?
    (Don't keep it off that's a bad idea)
    It's been off, I found it annoying and turned it off a while ago

  25. #65
    (Sorry for triple post)

    So I turned UAC back on and was able to apply the changing of read-only attributes to every other folder in program files (x86) except for the lucasarts folder, which it, and the subsets. will still not allow me to change the folder properties (well not not allow me, but they just won't change)

  26. #66
    Child's Play CharityRibberium Mempyre!

    Posts
    12,497
    Yeah uh, keeping UAC off breaks permissions because windows doesn't want a program to go ****ing about with UAC off.
    Try copying it to another folder first, see if you can turn off read only on the clone.

  27. #67
    Hmm, apparently with UAC on or off even if I make a new empty folder, I get the same problem of not being able to make the folder not read-only.

    I have absolutley no idea how to fix this

  28. #68
    Imon, umon...everymon!
    Posts
    19,021
    Quote Originally Posted by Tibby View Post
    Yeah uh, keeping UAC off breaks permissions because windows doesn't want a program to go ****ing about with UAC off.
    No.

    TSM_Bguitar, can you post screenshots of the screens you're looking at?
    Bassoon, n. A brazen instrument into which a fool blows out his brains.

  29. #69
    Child's Play CharityRibberium Mempyre!

    Posts
    12,497
    He did, go up a bit.

  30. #70
    Hmm I tried with UAC on and off, same bizarre problem, still no JK working

  31. #71
    Child's Play CharityRibberium Mempyre!

    Posts
    12,497
    Seems to me now that this is less an issue with JK and more an issue with Windows, you might want to try a forum dedicated to Windows problems, make a new post here, or if you can go post in SH/SC.

  32. #72
    Imon, umon...everymon!
    Posts
    19,021
    Quote Originally Posted by Tibby View Post
    He did, go up a bit.
    ...no, he didn't. I want to make sure TSB_bguitar is changing the permissions correctly because the permissions dialogs are pretty poor in terms of usability.
    Bassoon, n. A brazen instrument into which a fool blows out his brains.

  33. #73
    Yeah how about a WHOLE screenshot of the window you're looking at to change the permissions
    "Nulla tenaci invia est via"

  34. #74
    No.

    TSM_Bguitar, can you post screenshots of the screens you're looking at?
    Sure:

    I'll uncheck the read-only box, then apply, or okay it, and it just returns after i reopen the same box.

    I've tried this with UAC on, with UAC off, and various other methods

    Seems to me now that this is less an issue with JK and more an issue with Windows, you might want to try a forum dedicated to Windows problems, make a new post here, or if you can go post in SH/SC.
    Yeah, it does seem to be a Windows problem indeed. Thank you guys for your help though.

  35. #75
    Imon, umon...everymon!
    Posts
    19,021
    You said you can't change ownership using the security tab?
    Bassoon, n. A brazen instrument into which a fool blows out his brains.

  36. #76
    Nope, it starts as the creator, then I'll click my own user-name and try to apply it and it just doesn't work

  37. #77
    Is your user account in Win7 an administrator?
    "Nulla tenaci invia est via"

  38. #78
    Yes, it's the only account

  39. #79
    Imon, umon...everymon!
    Posts
    19,021
    I'm at work on an XP machine so I can't check, but I think you're using the dialog wrong. Not your fault though, it's dumb and confusing. I'll look when I get home.
    Bassoon, n. A brazen instrument into which a fool blows out his brains.

  40. #80
    Child's Play CharityRibberium Mempyre!

    Posts
    12,497
    ddraw.dll seems to be broken for me, can someone download the latest zip from the link and see if it's corrupt?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •