Page 5 of 10 FirstFirst ... 34567 ... LastLast
Results 161 to 200 of 367

Thread: Jedi Knight issues

  1. #161
    Child's Play CharityRibberium Mempyre!

    Posts
    12,497
    All I can say is try turning enhanced off, I have no idea whats causing that.

  2. #162
    Just wanted to report that the links for reverting to patch 1.0 and the jedi knight enhanced aren't working.

    seems jkhub is dead?
    Last edited by GanjaStar; 03-23-2012 at 06:23 AM.

  3. #163
    Child's Play CharityRibberium Mempyre!

    Posts
    12,497
    ****, the site moved I'll have to fix those links.

  4. #164
    Quote Originally Posted by Tibby View Post
    ****, the site moved I'll have to fix those links.
    I managed to find where the site was moved with google, but I only found links for JK Enhanced and the ddraw.dll.

    I cannot find the links for the patch 10 revert tool, nor the unooficial patch, which seems to be required for the Enhanced pack.

    can anyone help please?

  5. #165
    For any existing links, simply replace www.jkhub.net with jkhub.massassi.net and it should work fine. The jkhub.net domain registration is not under the control of anyone contactable, unfortunately.

  6. #166
    Thanks guys, I managed to get everything I need

    Cannot wait to re experience one of the best FPS games from the golden age of PC games

    However, even though the links in the first post appear to be fixed, once you click on them, they still take you to the old jkhub pages, which don't work.

    I think Tibby that you only changed the link display, not the actual link content.

  7. #167
    It's me again, seems i'm the only one playing this these days

    I found the mysteries of the sith enhanced mod, but there is no retexture mod. Will the JK retexture mod work with mots?

    Also, is there a way to just exrtact the unnofical patch from the TODOA?
    Last edited by GanjaStar; 03-26-2012 at 12:21 PM.

  8. #168
    Quote Originally Posted by Dr. Doom View Post
    I had to rename the JK.exe in order to get it to run.

    Thanks in advance
    I can confirm the same thing.

    Steam version, win7 64bit. with jk.exe and all fixes from the thread, game won't launch either from steam or directory. Then i renamed the exe to dark forces II.exe

    and the game started up fine.

    Only difference is i have a gtx260 not a 460.
    Last edited by GanjaStar; 03-26-2012 at 01:44 PM.

  9. #169
    Its impossible to play TODOA because of jkhub being down,

    jkversions always crashes with an error while trying to download something from jkhub Im guessing.

    so there is no way for me to revert to 1.0 exe with the steam version...

    Im trying to get TODOA patcher working because I'm hoping the fixed widescreen. ATM, widescreen works, but its Vert-. top and bottom of the screen are cut of a bit.
    Last edited by GanjaStar; 03-27-2012 at 02:48 AM.

  10. #170

    NIKVMVS-REX-TODOA

    Posts
    16,951
    The JKVersions tool was made by The MAZZTer and it seems to work on every other system. However, now that the JKHub URL has changed it doesn't work on my end either (even if it doesn't seem to crash at the point when it's retrieving anything from JKHub but eh, what do I know). Unfortunately all the unofficial patches for JK need the v. 1.00 EXE from the original CD.

    Man, I didn't expect the server changes and Zeq's departure to actually cause bad things to me. Here's hoping the JKVersions tool can be fixed soon...

  11. #171
    Quote Originally Posted by FastGamerr View Post
    The JKVersions tool was made by The MAZZTer and it seems to work on every other system. However, now that the JKHub URL has changed it doesn't work on my end either (even if it doesn't seem to crash at the point when it's retrieving anything from JKHub but eh, what do I know). Unfortunately all the unofficial patches for JK need the v. 1.00 EXE from the original CD.

    Man, I didn't expect the server changes and Zeq's departure to actually cause bad things to me. Here's hoping the JKVersions tool can be fixed soon...
    Yeah that is the tool I used, and it always stops with an error.

    If anyone could send me the 1.0 exe file It would be great. I can provide proof that I own the whole Jedi knight collection on steam.

    I even have the original cd's for both the main game, and the expansion. However, I do not have a cd or dvd rom on my PC anymore :|

  12. #172
    Child's Play CharityRibberium Mempyre!

    Posts
    12,497
    I think there is a link in the OP pointing to it on the lucasarts ftp. Also this game is so damn old that I don't think anyone really cares about proving ownership.

  13. #173
    I ended up "acquiring" retail copies of the game, because I want to play TODOA and mysteries of the Sith steam version didn't work at all. The unofficial patcher doesn't work on the steam version.

    So now I have fully functional Mysteries of the sith updated and enhanced + TODOA rdy, since I finished the main game. Its amazing how well it still holds up.

  14. #174
    Child's Play CharityRibberium Mempyre!

    Posts
    12,497
    The level design is legit good, especially things like the part in level 9 where you ascend in that elevator for like, a whole kilometer, and can see the ship. I don't think any other engine could do that.

  15. #175
    Quote Originally Posted by Tibby View Post
    All I can say is try turning enhanced off, I have no idea whats causing that.
    Well that's disappointing... I can't believe nobody has ever seen this problem before...

  16. #176

    NIKVMVS-REX-TODOA

    Posts
    16,951
    I have. Sorry, I didn't check the previous page so I didn't know there were any open issues. Then again, I don't know if I can help.

    Which unofficial patch do you have installed? And on that note, does the saber appear like that in every level? The width of the saber's core as well as other measures are handled by COG commands and the level in question (12?) doesn't have a level-specific cog that would define those measures.

    In this screenshot I've used Xzero's latest unofficial patch.



    From left to right: Normal saber in L12, Xzero's saber in L12, normal saber in L04, Xzero's saber in L04

    So I had to use cheats to get the saber in L12 because there's no cog that would automatically give it to you in that level. And since there also aren't any commands to define the specific measures, it looks quite similar to the saber you posted. Xzero's saber, however, looks proper because the saber measurements have already been defined in kyle.cog used by the mod in question. However, in level 4 the situation's different because the level's main cog overrides kyle.cog so Xzero's saber looks like a long and quite fancy toothpick.

    In other words, it would require some cogging to make the sabers look proper in every level of the main JK campaign with all the patches installed.

  17. #177
    I'm using an old patch from 2006. Where do I get xzero's newest?

    E: And yes, it's like that in every level I've tried so far.

  18. #178

    NIKVMVS-REX-TODOA

    Posts
    16,951
    2006 is indeed quite old. The latest patch under the "Unofficial Patches" title is from January 2008 and can be downloaded from this page.

    Xzero's patch doesn't have a separate release but it's a part of TODOA TC. It mainly just enables widescreen mode and the new lightsabers.

  19. #179
    Ok, I had to reinstall JK using the Vista installer since TODOA TC requires a vanilla starting point. When I try to run the game, everything works fine, until I try to load my saves. Then it either crashes or tells me that it cannot load that game.

  20. #180

    NIKVMVS-REX-TODOA

    Posts
    16,951
    I assume you're playing the normal campaign (i.e. The Force Within)? I just played the first level for a bit (with the Xzero-patched JK.EXE) and I was able to load savegames properly. Then again, I don't have any other mods installed at the moment and I ran JK through a .BAT file (with the following content: JK.EXE -windowgui -debug log -devmode ).

  21. #181
    Yeah, the original campaign.

    How do you run the stuff from the TODOA pack without running the mod itself? I tried running the target to the TODOATC_SP folder, and clicking on the TODOATC_SP batch file itself. Both will allow me to run the mod, but I can't access the original content from there.

  22. #182

    NIKVMVS-REX-TODOA

    Posts
    16,951
    Well, that would actually require a bit of messing around with the resources to fully make it work. Getting TODOA TC MP and just running the TODOATC_ENGINE.gob file as a mod (i.e. that GOB being the only file in the directory) would get you somewhat far, though.

  23. #183
    *sigh*
    When I try running just the multiplayer engine file, it only lets me run multiplayer games... There has to be an easier way to do this. I just want to run JK enhanced.

  24. #184

    NIKVMVS-REX-TODOA

    Posts
    16,951
    Did you try the January 2008 Unofficial Patch yet? I don't remember facing any saber-related issues with that patch + JKE... but then again, it's been a while since I last tried it.

  25. #185
    Trying to get that to work now... I've apparently screwed something up bad... It keeps crashing even with the vanilla game now.

    EDIT: Well, for reasons that escape me, it suddenly works. I reinstalled JK again, and then ran the Jan 08' unofficial patch, and then installed JKE. Everything seems fine now. And the lightsaber is finally normal. Not sure what I did differently this time than I did the first time, but I'm not complaining.

    Thanks so much Fast.
    Last edited by Tarheel; 04-01-2012 at 07:36 AM.

  26. #186

    NIKVMVS-REX-TODOA

    Posts
    16,951
    Glad to hear it all worked out in the end!

  27. #187
    Child's Play CharityRibberium Mempyre!

    Posts
    12,497
    Multiplayer engine file?

  28. #188

    NIKVMVS-REX-TODOA

    Posts
    16,951
    Quote Originally Posted by GanjaStar View Post
    jkversions always crashes with an error while trying to download something from jkhub Im guessing.
    The latest version of JKVersions can be downloaded from JKHub. Thanks, The_MAZZTer!

  29. #189
    This comes from a watcher of my tutorial on how to get JK Enhanced running:
    "
    Hi, how are you? I was going to dowload Jedi Knight and Mysteries of the Sith from Steam, but I have windows 7 and a GTX 560 video card. Wouldn't I have problems playing it given how dated it is; and by the way would you by any chance know of a Mysteries of the Sith enhanced or retextured mod?
    "
    "Part of the problem is the people at JKhub don't know they are having DNS issues, therefore Internet Explorer can't display the web pages to get the patches I need. Futhermore, my video card is not made by Nvidia, it's by EVGA. Its a GeForce GTX 560ti superclocked."
    I don't know the answer to the watcher's questions; does anyone here know?

  30. #190
    Child's Play CharityRibberium Mempyre!

    Posts
    12,497
    It doesn't matter what 3rd party "made" your card, it's all to Nvidia spec. Also you can use JK enhanced with MoTS following the same instructions, except with MoTS, as far as I know.

  31. #191

    NIKVMVS-REX-TODOA

    Posts
    16,951
    MotS Graphical Update, download link here. By no means complete but it's a start.
    Last edited by Nikumubeki; 04-08-2012 at 02:40 AM.

  32. #192
    Child's Play CharityRibberium Mempyre!

    Posts
    12,497
    Woah, that's new.

  33. #193
    Human Computer
    Posts
    2,825
    Some of the links in the initial post need to be updated again. :-/
    ? :)

  34. #194
    Weird, very weird. JK1 from steam worked absolutely fine yesterday after following the instructions to fix the JKE mod.
    I tried to launch it today, nothing happens, my visual themes disable for about half a second then go back to normal, nothing launches at all.

    Only change on my system since yesterday was I downloaded MOTS from Steam. It doesn't launch either, have not made any changes to it.

    Edit:

    Even more weird, if I rename the EXE then launch it, the game works fine, but if its called JK.exe it won't launch.
    Last edited by Tuskin38; 04-22-2012 at 10:40 AM.

  35. #195
    Child's Play CharityRibberium Mempyre!

    Posts
    12,497
    Turn off steam community overlay?

  36. #196
    Quote Originally Posted by Tibby View Post
    Turn off steam community overlay?
    It was on yesterday and the game was working fine.

    But no, disabling did not help.
    Is there a Legal way to get a non Steam MOTS exe? if I have that and rename it something different it should work like JK1 works. If I rename the steam MOTS exe it just gives a steam error when launching.
    Last edited by Tuskin38; 04-22-2012 at 03:46 PM.

  37. #197
    The monster at the end of this thread
    Posts
    446
    Quote Originally Posted by Shieara View Post
    Okay need a bit of help here.

    I have the Steam version. It runs fine with no mods/enhancements using the 8 bit mode. If I try to turn on any graphics acceleration, either with or without mods, I get this...



    I did eventually get the graphic acceleration to work by enabling the advanced display mode and going to RGB Emulation mode, but now there is a black box when I shoot and I am having frame-rate issues. This is with or without mods. I have tried the ddraw.dll file with no success. Any ideas?

    I run...
    WinXP sp3
    intel core i7 2600K processer
    geforce gtx 470

    Sorry to respond to an oldish thread, but at my wits end on this one.

    Hey, I ran into this same problem recently, when I installed another Nvidia videocard, and the drivers for it. It is strictly a drivers issue, I had to download a much older version of the drivers, then uninstall the current nvidia drivers from my system and install the old ones from scratch in order to fix it. I downloaded and installed multiple drivers before finding one that worked. The drivers I finally installed were for an NVIDIA Geforce 8800 GS Driver version 6.14.12.6089, and Driver date 10/8/2010. Hope this helps.

  38. #198
    Registered User
    Posts
    35
    Hey guys:I have a problem.
    When going into a server get stuck on the screen Contacting host server or something.
    And do not enter.

    Can you help?
    I think the port is right,because without the port just stayed in the infamous screen searching.

  39. #199
    Child's Play CharityRibberium Mempyre!

    Posts
    12,497
    If you are running JK on a newer OS there might be firewall difficulties. I suggest just using Hamachi.

  40. #200

    NIKVMVS-REX-TODOA

    Posts
    16,951
    Quote Originally Posted by Tuskin38 View Post
    Is there a Legal way to get a non Steam MOTS exe?
    Aside from getting the CD version, no.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •