Massassi Forums Logo

This is the static archive of the Massassi Forums. The forums are closed indefinitely. Thanks for all the memories!

You can also download Super Old Archived Message Boards from when Massassi first started.

"View" counts are as of the day the forums were archived, and will no longer increase.

ForumsDiscussion Forum → Jedi Knight issues
Jedi Knight issues
2010-03-08, 4:11 PM #1
Unofficial official Jedi Knight issues FAQ thread.
Please, for the love of all that is holy, read this post over before you post.
Please also note that all of the following works for Mysteries of the Sith as well.

1. JK won't install/it says something about 16 bit.
Use this progam:§ion=downloads

2. JK Won't start, it crashes seconds after starting.
JK doesn't like newer hardware, for some reason it crashes when it runs the GUI (The Menu) in fullscreen. Use the -Windowgui command line.
3. JK starts but the display has issues.
Use this fix ZeqMacaw made:
(Simply put the ddraw.dll (downloadable zip file) in the folder with your JK.EXE or JKM.EXE file and start JK or MotS normally.)-ZeqMacaw

The above is now DEPRECATED, but left here just in case.
The current solution is to run a batch file:

@echo off
taskkill /f /IM explorer.exe
start /wait jk.exe
start C:\Windows\explorer.exe

You don't need the DDRAW hack for this. The menu starts blank, just alt-tab out and then back in to see it, or append -windowgui to jk.exe if you prefer doing it that way.
Credit goes partially to GOG, I modified this code from their RCT release.
4. Some new levels ask for unoffical patches, what are those?
The JK engine had some limits that at the time seemed reasonable, but mod devs never stay within the bounds of the engine they work.
Find them here. TODOA also has an auto-installer.

5. I have steam JK and those won't work.
Steam JK is the patched version 1.01 that nobody ever used and nothing is properly programmed for.
Use this useful patch from The_Mega_ZZTer to revert to 1.0

6. My textures are messed up with Jedi Knight Enhanced and the Steam version.
Follow this step by step method written by joel96.
Originally posted by joel96:
A bunch of people helped me get it working. I made a video tutorial to simplify the process, and uploaded a single .7z file with everything you need to get the best texture sets working. Here's the link to the video tutorial:

Install these:
Windows .NET Framework:
Your latest video card drivers with Steam
Star Wars Jedi Knight: Dark Forces II from Steam

The .7z contains these, so you can ignore the links and do what the instructions say.
Get smackw32.dll: -> your main jedi knight folder
Get jkpatch: -> main jedi knight folder

Get Jedi Knight Enhanced:
Get Jedi Knight Retexture:
Create a folder called "Mod"
Drop JKE.gob and JKR.gob into Mod
RMB JK.exe-> Properties -> Compatibility. Check Disable visual themes and check Disable desktop composition. Click Apply. RMB JK.exe -> Create shortcut.
RMB JK.exe - Shortcut -> Properties. At the end of the Target line, type in "-windowgui -path Mod" Click Apply.

Double-click JK.exe - Shortcut to start the game. Go to Players -> Single Player. Create a profile. After the game starts, hit Esc -> Setup -> Display. Check Enable 3D Acceleration. Check Backbuffer in System Memory. Set 3D Accelerator min texture size to 1. Select your screen resolution and bit depth.

If you have a save game you want to continue, then you will have to end the level first to get the textures working. Hit the t key -> type in thereisnotry and hit Enter.

Useful Links:
Jedi Knight Enhanced: A great retexture/remodel pack.
Patch Commander: It's back!

List of things to try before posting:

Everything in this post
Running it as admin/ in compatibility modes.
Updating drivers.
Exiting Catalyst Control Center/ATi Tray Tools/Whatever the Nvidia equivalent is.
Checking your disks for any damage.
Make sure it's a game issue, not a windows issue- A problem copying files/setting permissions is an example of something you should ask about elsewhere.
Try other resolutions ingame.
Changing to windows basic/turning off aero.
Everything in this post again.

So you've read this post twice, and tried everything? Here's what to include in your post:
Operating system, 32 or 64 bit.
Video card, processor. (We don't need to know anything else, nor do we care about your power supply.)
Any programs running in the background that might interfere, make sure you have tried turning them off first.
I'll add to this as I see fit, and merge in anything I see useful. Feel free to post JK related questions in the thread and me or another member will do our best to help you.
VMware 8 or Fusion 5 seem to work pretty well, but it's finicky.
Also try switching to Intel Graphics if your computer supports that, JK works fine on HD3000/4000.

Non-Inclusive list of what works with JK.

Windows 95,98, 98SE, 2000, XP, Vista, 7.
Any processor, it doesn't seem to matter.
Any display type, or resolution. JK seems to be able to detect displays extremely well, I've seen it work on 2560 displays.
Pre-DX10 Nvidia or ATi cards, post-DX10 gets weird, and you will probably have to use the DDRAW.DLL fix. The newer the card, the less likely the fix will work.
Intel HD 3000/4000 works fine on native Windows 7 with the DDRAW fix. If you're computer has dual graphics try switching.
MacBook note: While it works with HD4000, and VMWare- OSX has a different driver setup then Windows and JK is unlikely to work in a VM. I suggest using bootcamp, confirmed to work on a 13'' mid 2012.
VMWare 8, Fusion 5. Use the DDRAW.dll fix and a Win2K virtual machine. XP may or may not work.

Confirmed to be totally broken:

Windows 8
Wine on OSX.
Parallels or virtualbox VM.
2010-03-08, 8:29 PM #2
Originally posted by Tibby:
(Sticky please)


FYI UJMM has been discontinued in favor of Knight, which I recoded from the ground up except for a few of the core bits for reading GOB files.

2010-03-09, 7:34 AM #3
Having to go through all of those steps just to play a game that no one plays anymore really makes me not want to play it anymore either. :(
? :)
2010-03-09, 7:50 AM #4
I've only just realised:

Tibby - Tibshelf Services.

Probably have to be a Britassian to get that one though.
2010-03-09, 9:02 AM #5
This looks pretty helpful. It would be nice to add exact error text where appropriate to help with search keywords and so on.
2010-03-09, 10:53 AM #6
Add the info to the FAQ on the main page.
2010-03-09, 11:50 AM #7
Originally posted by Brian:
Add the info to the FAQ on the main page.

That's a good idea.

you hear me coolmatty make your website like I tell you or else :argh:
2010-03-09, 2:31 PM #8
Originally posted by Brian:
Add the info to the FAQ on the main page.

I think this way works better, new problems can be posted and the FAQ edited instantly.
2010-03-09, 2:47 PM #9
Your installation, etc are all working instructions but I have something more Tibby that you'll probably figure out.

When I use your solutions, everything works perfect, however I want to play JK with JK Enhanced running. Whenever I run my JK with the -windowgui and -jke added to the command line it launches JK without JK Enhanced running. For some reason it ignores the -JKE part of the command line, I don't know why... BUt basically, how do you get your working solutions to work with JKE?
2010-03-09, 2:52 PM #10
Put the JKE gob into a folder market JKE inside Jedi Knights folder.
The command line is -path JKE.
2010-03-09, 10:45 PM #11
stay on topic or ban kthx
[01:52] <~Nikumubeki> Because it's MBEGGAR BEGS LIKE A BEGONI.
2010-03-13, 7:36 AM #12
You may want to include some instructions w/ your link to ZeqMacaw's DDRAW.DLL fix. Your link takes you directly to a download that doesn't include a README. I would suggest just copying & pasting ZeqMacaw's instructions from JKHUB.

Simply put the ddraw.dll (downloadable zip file) in the folder with your JK.EXE or JKM.EXE file and start JK or MotS normally.
? :)
2010-03-13, 7:55 AM #13
I have everything up & running nicely in Windows 7 on my Mac, except JED/ZED. Does anyone know how to resolve the following error? It appears when I launch JED/ZED.

The program can't start because D3DRM.DLL is missing from your computer. try reinstalling the program to fix this problem.

Edit: I updated my video card driver & DirectX to no avail.
? :)
2010-03-13, 9:29 AM #14
You have to google that dll, download it and put it in a certain folder (sorry I forget where).
2010-03-13, 10:31 AM #15
I had to download D3DRM.DLL & place it in to my JED/ZED directory to resolve the issue. Thanks for your help.
? :)
2010-03-13, 10:33 AM #16
Now I've run in to another issue. JKLauncher installs just fine but when I go to launch it, it shows up in the taskbar but when I go to use it the icon disappears. Anyone have any experience w/ this one?
? :)
2010-03-13, 11:01 AM #17
Originally posted by Mentat:
Now I've run in to another issue. JKLauncher installs just fine but when I go to launch it, it shows up in the taskbar but when I go to use it the icon disappears. Anyone have any experience w/ this one?

(JKLE_Cougar) from JK MP Community
2010-03-13, 11:07 AM #18
Originally posted by Mentat:
You may want to include some instructions w/ your link to ZeqMacaw's DDRAW.DLL fix. Your link takes you directly to a download that doesn't include a README. I would suggest just copying & pasting ZeqMacaw's instructions from JKHUB.

Good idea.
As for that DLL issue, yeah just google it.
JKlauncher... Try reinstalling it.
2010-03-14, 11:03 AM #19
Ok, when I turn on 3D Acceleration and choose 1024 x 768, the level goes black and crashes right after loading. It seems to work if I don't turn on the acceleration, and that may be what I have to live with.

Here's what I've already done:

1. Put Zeq's ddraw.dll in the JK folder.

2. Made a new shortcut to JK.EXE with the command line parameter -windowgui

3. Turned on Win98 compatability mode

4. Selected "Disable Visual Themes" and selected "Turn off advanced text services"

Any solutions besides just running 8-bit textures with 3-D Acceleration off?

System Specs:
Windows XP SP3
Pentium 4 3.2
nVidia GeForce 7950GT
1 Gb Ram
"Harriet, sweet Harriet - hard-hearted harbinger of haggis."
2010-03-14, 12:11 PM #20
Don't use compatibility modes, they are useless.
That system should be able to run JK native, did you try?
What level are you running? Just one of the default ones?
2010-03-14, 1:49 PM #21
yep, default.
"Harriet, sweet Harriet - hard-hearted harbinger of haggis."
2010-03-14, 3:05 PM #22
I'm at a loss here, I've played JK on a 7XXX series card on XP natively before, Are you sure you ran it without any patches/hacks first?
2010-03-14, 3:29 PM #23
I uninstalled it, deleted the folder, and reinstalled it just to be sure.
"Harriet, sweet Harriet - hard-hearted harbinger of haggis."
2010-03-14, 3:37 PM #24
Drivers up to date?
DX9 up to date?
Are the drivers doing anything weird? I know when I tried to force AA and AF through Nvidia Control panel it didn't work.
If none of the above.. Try older drivers.
2010-03-16, 11:28 PM #25
I did Step 1 (because I can't even get the game to install). All I get when trying to run the game is a Cannot Load Error followed by some Chinese writing or Japanese.

arrgh!!!! I'm about to give up trying to get this game to go.
2010-03-17, 11:23 AM #26
Did you read through the other instructions, specifically windowgui?
2010-03-18, 10:40 AM #27
Another helpful tidbit when installing JK & MotS using this method is that you probably need to be logged in as administrator to complete step 6 of the "Install JK" tutorial. You'll know when the attribute change didn't complete because you'll ge the following error: ERR_CANNOT_LOAD_FILE (followed by Asian characters).
? :)
2010-03-18, 9:18 PM #28
If you receive this error when running JK/MotS:


Ensure you copied all the files necessary from the CD, especially the resource GOB/GOO files.

2010-03-22, 8:16 AM #29

Well, this is for XP. You others will have to adapt to your OS.

1. Go to Control Panel and open the Sound and Audio Devices.

2. Dial back the performance of the Hardware Acceleration to about the second tick.

3. Enjoy MotS cutscenes at normal speed.

I don't know why this works, and I certainly didn't come up with it myself. I saw it on the Steam forums and thought it was worth a repost.
Attachment: 23653/audiofix.jpg (53,094 bytes)
"Harriet, sweet Harriet - hard-hearted harbinger of haggis."
2010-03-22, 1:33 PM #30
Before I put that in the OP, can someone else confirm it's not a fluke?
Nothing against you, I just want to be sure this isn't a one-off fix.
2010-03-22, 3:21 PM #31
Try it, I dares ya!
"Harriet, sweet Harriet - hard-hearted harbinger of haggis."
2010-03-22, 3:25 PM #32
I don't have XP. :\ and they have always worked fine for me.
E: Yeah, it works fine for me without any hacks.
2010-03-22, 8:47 PM #33
Even if it doesn't work for anyone else (which I'm 99.9% convinced it will now), I KNOW it works for me. Just today, the few times I forgot to set the acceleration back, the cutscenes would speed through on fast forward.
"Harriet, sweet Harriet - hard-hearted harbinger of haggis."
2010-03-22, 9:09 PM #34
Well good for you, I'll keep in mind if someone comes in with that problem, but I stand by not adding every single personal fix to the OP.
2010-03-23, 7:45 AM #35
Not a problem. If some of these others will get off their duffs and try it, I think it will be confirmed.
"Harriet, sweet Harriet - hard-hearted harbinger of haggis."
2010-03-23, 8:13 PM #36
I never had a problem with cutscene speed in XP so it's probably specific to your hardware.

On the other hand my sound hardware did not support hardware acceleration anyway. So it might have just not affected me.

2010-03-23, 8:49 PM #37
Actually you gave me an idea, I have a P4 with an Audigy SE in the basement, I'll through MotS on it later and see if I can confirm this.
E: Christ, it's ****ed. This is going to take a while to fix so nobody hold their breath on my findings.
2010-03-23, 9:56 PM #38
I had the same problem back in June of last year - the thread. Wasn't able to resolve it then, but sounds like I was getting close.

Here is the thread on the Steam forums where I found the answer. At first they (somebody) recommended turning on subtitles, but that didn't work. And then someone mentioned this fix for Curse of Monkey Island and that it should/did work for MotS.

I'm just saying I didn't pull all of this out of my arse.
"Harriet, sweet Harriet - hard-hearted harbinger of haggis."
2010-03-24, 5:57 AM #39
I don't think this is even an option in Windows Vista/7
2010-03-24, 10:06 AM #40
Originally posted by Cool Matty:
I don't think this is even an option in Windows Vista/7

because there is no hardware sound in Vista/7.

Edit: well, basically.

↑ Up to the top!